मुख्य विंडो

OpenShot Video Editor में एक मुख्य विंडो होती है जिसमें आपके वीडियो प्रोजेक्ट को संपादित करने के लिए आवश्यक अधिकांश जानकारी, बटन और मेनू होते हैं।

समीक्षा

../_images/main-window.jpg

क्रमांक

नाम

विवरण

1

मुख्य टूलबार

इसमें आपके वीडियो प्रोजेक्ट को खोलने, सहेजने और निर्यात करने के लिए बटन होते हैं।

2

फ़ंक्शन टैब

प्रोजेक्ट फाइलें, ट्रांज़िशन, इफेक्ट्स, और इमोजी के बीच स्विच करें।

3

प्रोजेक्ट फाइलें

सभी ऑडियो, वीडियो, और छवि फाइलें जो आपके प्रोजेक्ट में आयात की गई हैं।

4

पूर्वावलोकन विंडो

यह वह क्षेत्र है जहाँ वीडियो स्क्रीन पर प्लेबैक होगा।

5

टाइमलाइन टूलबार

इस टूलबार में स्नैपिंग, मार्कर डालने, रेज़र से काटने, मार्करों के बीच कूदने, और प्लेहेड पर टाइमलाइन को केंद्रित करने के लिए बटन होते हैं। देखें टाइमलाइन टूलबार

6

ज़ूम स्लाइडर

यह स्लाइडर आपकी टाइमलाइन के टाइम-स्केल को समायोजित करेगा। ज़ूम इन या आउट करने के लिए बाएँ या दाएँ किनारे को खींचें। टाइमलाइन को बाएँ या दाएँ स्क्रॉल करने के लिए नीले क्षेत्र को खींचें। क्लिप्स और ट्रांज़िशन सरल आयतों के रूप में दिखाए जाते हैं, ताकि आप विशिष्ट क्लिप्स के लिए ज़ूम समायोजित कर सकें।

7

प्लेहेड / रूलर

रूलर समय-स्केल दिखाता है, और रेखा प्ले-हेड होती है। प्ले-हेड वर्तमान प्लेबैक स्थिति का प्रतिनिधित्व करता है। वर्तमान टाइमकोड पर क्लिक करके सटीक टाइमकोड दर्ज किया जा सकता है। प्लेहेड को खींचते समय Shift कुंजी दबाए रखें ताकि यह नजदीकी क्लिप्स से चिपक जाए।

8

टाइमलाइन

टाइमलाइन आपके वीडियो प्रोजेक्ट और आपके प्रोजेक्ट के प्रत्येक क्लिप और ट्रांज़िशन को दृश्य रूप में दिखाती है। आप कई आइटम्स को चुनने, स्थानांतरित करने, या हटाने के लिए माउस खींच सकते हैं।

9

फ़िल्टर

दिखाए गए आइटम्स (प्रोजेक्ट फाइलें, ट्रांज़िशन, इफेक्ट्स, और इमोजी) की सूची को इन बटनों और फ़िल्टर टेक्स्टबॉक्स का उपयोग करके फ़िल्टर करें। जो आप खोज रहे हैं उसके कुछ अक्षर दर्ज करें, और परिणाम दिखाए जाएंगे।

10

प्लेबैक

बाएँ से दाएँ: शुरुआत पर जाएं, रिवाइंड, प्ले/पॉज़, फास्ट फॉरवर्ड, और अंत में जाएं

11

ट्रैक

ट्रैक क्षेत्र जिसमें ट्रैक का नाम, ट्रैक मेनू, और प्रति-ट्रैक नियंत्रण जैसे लॉक और कीफ़्रेम पैनल आइकन शामिल हैं।

OpenShot के बुनियादी उपयोग के लिए चरण-दर-चरण निर्देशों के लिए, त्वरित ट्यूटोरियल पढ़ना सुनिश्चित करें।

बिल्ट-इन ट्यूटोरियल

जब आप पहली बार OpenShot लॉन्च करते हैं, तो आपको एक मित्रवत बिल्ट-इन ट्यूटोरियल दिखाया जाएगा। यह मूल बातें प्रदर्शित और समझाएगा। Next पर क्लिक करने से अगली विषय पर जाया जाएगा। आप हमेशा इस ट्यूटोरियल को Help→Tutorial मेनू से फिर से देख सकते हैं।

../_images/built-in-tutorial.jpg

ट्रैक्स और लेयर्स

OpenShot वीडियो और छवियों को लेयर करने के लिए ट्रैक्स का उपयोग करता है। सबसे ऊपर वाला ट्रैक शीर्ष लेयर होता है, और सबसे नीचे वाला ट्रैक निचली लेयर। यदि आप फोटो संपादन एप्लिकेशन में लेयर्स से परिचित हैं, तो यह अवधारणा आपके लिए परिचित होगी। OpenShot लेयर्स को स्टैक करता है और प्रत्येक को मिलाता है, ठीक एक फोटो संपादन एप्लिकेशन की तरह। आपके पास असीमित ट्रैक्स हो सकते हैं, लेकिन आमतौर पर एक साधारण वीडियो प्रोजेक्ट को 5 से अधिक ट्रैक्स की आवश्यकता नहीं होती।

उदाहरण के लिए, एक 3 ट्रैक वीडियो प्रोजेक्ट की कल्पना करें

../_images/tracks.jpg

क्रमांक

नाम

विवरण

1

शीर्ष ट्रैक

इस ट्रैक पर क्लिप्स हमेशा ऊपर और दिखाई देंगे। अक्सर वॉटरमार्क और शीर्षक उच्च ट्रैक्स पर रखे जाते हैं।

2

मध्य ट्रैक

मध्य में क्लिप्स (जो ऊपर क्या है उस पर निर्भर करते हुए दिखाई दे सकते हैं या नहीं)

3

निचला ट्रैक

इस ट्रैक पर क्लिप्स हमेशा नीचे होंगे। अक्सर ऑडियो क्लिप्स निचले ट्रैक्स पर रखे जाते हैं।

टाइमलाइन टूलबार

../_images/timeline.jpg

टाइमलाइन संपादन (चयन, ट्रैक, कीफ़्रेम, और सामान्य कार्यप्रवाह) का शुरुआती के लिए अनुकूल अवलोकन देखने के लिए, टाइमलाइन देखें।

क्रमांक

नियंत्रण समूह

विवरण

1

ट्रैक जोड़ें

टाइमलाइन में एक नया ट्रैक जोड़ें। नए प्रोजेक्ट्स डिफ़ॉल्ट रूप से 5 ट्रैक्स के साथ शुरू होते हैं।

2

पूर्ववत करें / पुनः करें

अपने नवीनतम टाइमलाइन संपादनों को पूर्ववत या पुनः करें।

3

स्नैप, रीटाइम, रेज़र

स्नैपिंग चुंबकीय संरेखण को चालू या बंद करता है। टाइमिंग टूल क्लिप किनारों को खींचकर रीटाइमिंग सक्षम करता है। रेज़र टूल क्लिक किए गए स्थान पर क्लिप्स को काटता है।

4

मार्कर जोड़ें, अगला/पिछला मार्कर

प्लेहेड पर एक मार्कर जोड़ें और पिछले या अगले मार्कर/क्लिप सीमाओं पर जाएं।

5

प्लेहेड पर केंद्रित करें

दृश्यमान टाइमलाइन क्षेत्र को वर्तमान प्लेहेड स्थिति के चारों ओर केंद्रित करें।

6

ज़ूम स्लाइडर

दृश्यमान टाइमलाइन सीमा को नियंत्रित करें। ज़ूम इन/आउट के लिए हैंडल खींचें, पैन के लिए केंद्र खींचें, और टाइमलाइन फिट करने के लिए डबल-क्लिक करें। आप Ctrl+Scroll Wheel का उपयोग भी कर सकते हैं, या QWidget टाइमलाइन पर Ctrl दबाकर मिडल माउस बटन से खींचकर स्मूथ ज़ूमिंग कर सकते हैं।

7

ट्रैक टॉगल (लॉक, कीफ़्रेम पैनल)

प्रति-ट्रैक नियंत्रण जैसे लॉक और कीफ़्रेम पैनल दृश्यता।

कीबोर्ड शॉर्टकट

यहाँ OpenShot द्वारा समर्थित डिफ़ॉल्ट कीबोर्ड शॉर्टकट की सूची है। आप इन शॉर्टकट्स को प्रेफरेंस विंडो में कॉन्फ़िगर कर सकते हैं, जिसे OpenShot मेनू बार से Edit→Preferences चुनकर खोला जाता है। (macOS पर, OpenShot Video Editor→Preferences चुनें।) कुछ शॉर्टकट सीखने से आपका काफी समय बच सकता है!

क्रिया

शॉर्टकट 1

शॉर्टकट 2

शॉर्टकट 3

OpenShot के बारे में

Ctrl+H

मार्कर जोड़ें

M

ट्रैक जोड़ें

Ctrl+Y

टाइमलाइन में जोड़ें

Ctrl+Alt+A

एनिमेटेड शीर्षक

Ctrl+Shift+T

एक प्रश्न पूछें...

F4

प्लेहेड पर केंद्रित करें

Shift+C

Alt+Up

रंग दृश्य

Alt+Shift+2

प्रोफ़ाइल चुनें

Ctrl+Alt+P

सभी कैश साफ़ करें

Ctrl+Shift+ESC

इतिहास साफ़ करें

Ctrl+Shift+H

संपादित वीडियो हटाएं

Ctrl+Shift+O

वेवफॉर्म डिस्प्ले डेटा साफ़ करें

Ctrl+Shift+W

कॉपी करें

Ctrl+C

काटें

Ctrl+X

आइटम हटाएं

Delete

Backspace

आइटम हटाएं (रिपल)

Shift+Delete

विवरण दृश्य

Ctrl+Page Up

दान करें

F7

डुप्लिकेट करें

Ctrl+Shift+/

शीर्षक संपादित करें

Alt+T

चयनित फ़ाइलें निर्यात करें

Ctrl+Shift+E

वीडियो / मीडिया निर्यात करें

Ctrl+E

Ctrl+M

फास्ट फॉरवर्ड

L

फ़ाइल गुण

Alt+I

Ctrl+Double Click

फुल स्क्रीन

F11

फ़ाइलें आयात करें...

Ctrl+I

कीफ्रेम डालें

Alt+Shift+K

हमारे समुदाय से जुड़ें...

F5

अंत में जाएं

End

शुरुआत में जाएं

Home

ट्यूटोरियल शुरू करें

F2

नया प्रोजेक्ट

Ctrl+N

अगला फ्रेम

Right

.

अगला मार्कर

Shift+M

Alt+Right

बाएँ सरकाएँ (1 फ्रेम)

Ctrl+Left

बाएँ सरकाएँ (5 फ्रेम)

Shift+Ctrl+Left

दाएँ सरकाएँ (1 फ्रेम)

Ctrl+Right

दाएँ सरकाएँ (5 फ्रेम)

Shift+Ctrl+Right

सहायता सामग्री खोलें

F1

प्रोजेक्ट खोलें...

Ctrl+O

चिपकाएँ

Ctrl+V

चलाएँ/रोकें टॉगल

Space

Up

Down

पसंद

Ctrl+P

फ़ाइल पूर्वावलोकन

Alt+P

Double Click

पिछला फ्रेम

Left

,

पिछला मार्कर

Ctrl+Shift+M

Alt+Left

गुण

U

बाहर निकलें

Ctrl+Q

रेज़र टॉगल

C

B

R

फिर से करें

Ctrl+Shift+Z

बग रिपोर्ट करें...

F3

पिछे जाएं

J

वर्तमान फ्रेम सहेजें

Ctrl+Shift+Y

वर्तमान फ्रेम सहेजें

Ctrl+Shift+Y

प्रोजेक्ट सहेजें

Ctrl+S

प्रोजेक्ट को इस नाम से सहेजें...

Ctrl+Shift+S

सभी चुनें

Ctrl+A

आइटम चुनें (रिपल)

Alt+A

Alt+Click

कोई चयन न करें

Ctrl+Shift+A

सरल दृश्य

Alt+Shift+0

सभी को काटें: दोनों पक्ष रखें

Ctrl+Shift+K

सभी को काटें: बायाँ पक्ष रखें

Ctrl+Shift+J

सभी को काटें: दायाँ पक्ष रखें

Ctrl+Shift+L

चयनित को काटें: दोनों पक्ष रखें

Ctrl+K

चयनित को काटें: बायाँ पक्ष रखें

Ctrl+J

चयनित को काटें: दायाँ पक्ष रखें

Ctrl+L

चयनित को काटें: बायाँ रखें (रिपल)

W

चयनित को काटें: दायाँ रखें (रिपल)

Q

स्नैपिंग टॉगल

S

फ़ाइल विभाजित करें

Alt+S

Shift+Double Click

थंबनेल दृश्य

Ctrl+Page Down

टाइमिंग टॉगल

T

शीर्षक

Ctrl+T

इस एप्लिकेशन का अनुवाद करें...

F6

पूर्ववत करें

Ctrl+Z

टूलबार देखें

Ctrl+Shift+B

ज़ूम इन करें

=

Ctrl+=

ज़ूम आउट करें

-

Ctrl+-

टाइमलाइन पर ज़ूम करें

\

Shift+\

Double Click

OpenShot के बारे में

Help→About OpenShot का उपयोग करके अपने OpenShot संस्करण की जांच करें। संस्करण संख्या के बगल में Copy पर क्लिक करें ताकि एक संक्षिप्त संस्करण और सिस्टम विवरण रिपोर्ट कॉपी हो जाए, जो बग रिपोर्ट करते समय या सहायता मांगते समय इस जानकारी को साझा करने का पसंदीदा तरीका है।

उदाहरण आउटपुट:

**OpenShot Version Info**
Version: 3.5.1-dev | libopenshot: 0.7.0
OS: Ubuntu 24.04
CPU: AMD Ryzen 7 8840HS w/ Radeon 780M Graphics (16 threads) | RAM: 15 GB
Cache: Memory, 900 MB, 905 frames, ahead 50%, pre-roll 24/48
Performance: Threads: OMP 16 | FFmpeg 16, Cards: Decode: None (0) | Encode: 0

व्यू

OpenShot मुख्य विंडो कई डॉक्स से बनी होती है। ये डॉक्स एक समूह में व्यवस्थित और स्नैप किए जाते हैं जिसे हम View कहते हैं। OpenShot में Simple View, Color View, और My Views (उपयोगकर्ता-परिभाषित लेआउट) शामिल हैं।

सरल दृश्य

यह डिफ़ॉल्ट दृश्य है, और इसे विशेष रूप से पहली बार उपयोग करने वालों के लिए आसान बनाने के लिए डिज़ाइन किया गया है। इसमें ऊपर बाएं Project Files, ऊपर दाएं Preview Window, और नीचे Timeline होता है। यदि आप गलती से कोई डॉक बंद या स्थानांतरित कर देते हैं, तो आप स्क्रीन के शीर्ष पर View->Simple View मेनू का उपयोग करके सभी डॉक्स को उनकी डिफ़ॉल्ट स्थिति में जल्दी से रीसेट कर सकते हैं।

रंग दृश्य

यह दृश्य रंग सुधार और स्कोप्स पर केंद्रित है। यह वीडियो पूर्वावलोकन को बड़ा करता है, फ़ाइल-प्रबंधन डॉक्स को छिपाता है, टाइमलाइन और गुणों को दृश्यमान रखता है, Color Wheels डॉक को दाईं ओर रखता है, और इसके नीचे Luma Waveform और Histogram डॉक्स को टैब में व्यवस्थित करता है।

रिकॉर्डिंग दृश्य

यह दृश्य OpenShot के अंदर नई रिकॉर्डिंग बनाने पर केंद्रित है। यह Project Files, Video Preview, Timeline, और Recording डॉक दिखाता है। Properties डॉक को Project Files के साथ एक टैब के रूप में समूहित किया गया है, ताकि आप इसे View->Docks->Properties से रिकॉर्डिंग लेआउट को बाधित किए बिना दिखा सकें।

Recording डॉक माइक्रोफोन ऑडियो, स्क्रीन कैप्चर, वेबकैम वीडियो, या उन स्रोतों के संयोजन को रिकॉर्ड कर सकता है। जब स्क्रीन और वेबकैम एक साथ रिकॉर्ड किए जाते हैं, तो OpenShot वेबकैम को एक कोने में पिक्चर-इन-पिक्चर क्लिप के रूप में रख सकता है। उन कोने के कैमरा क्लिप्स का उपयोग टाइमलाइन में जोड़ने के बाद सामान्य क्लिप गुणों के साथ होता है: Gravity कोना चुनता है, Scale X और Scale Y कोने का आकार सेट करते हैं, Margin इनसेट लेआउट क्षेत्र बनाता है जो कैमरा को स्क्रीन के किनारे से दूर रखता है, और Corner Radius कैमरा क्लिप को गोल करता है बिना अलग मास्क प्रभाव जोड़े। विवरण के लिए देखें क्लिप गुण। पूर्ण रिकॉर्डिंग वर्कफ़्लो और सभी स्रोत विकल्पों के लिए देखें रिकॉर्डिंग

मेरे दृश्य

My Views आपको किसी भी डॉक व्यवस्था को नामित लेआउट के रूप में सहेजने और तुरंत पुनः प्राप्त करने की अनुमति देता है। यह उन वर्कफ़्लोज़ के लिए आदर्श है जिन्हें विभिन्न संपादन मोड के बीच स्विच करने की आवश्यकता होती है — उदाहरण के लिए, एक विस्तृत ऑडियो मिक्स लेआउट और एक केंद्रित रंग ग्रेडिंग लेआउट — बिना हर बार डॉक्स को मैन्युअल रूप से पुनःस्थित किए।

प्रत्येक सहेजे गए दृश्य में हर डॉक की स्थिति, आकार, और दृश्यता के साथ-साथ टाइमलाइन की ऊंचाई भी कैप्चर होती है। सहेजे गए दृश्य आपके प्रोजेक्ट सेटिंग्स में संग्रहीत होते हैं और सत्रों के बीच बने रहते हैं।

View → My Views मेनू विकल्प:

मेनू आइटम

विवरण

उपयोगकर्ता-परिभाषित दृश्यों की सूची

उस लेआउट को पुनर्स्थापित करने के लिए क्लिक करें। वर्तमान सक्रिय दृश्य पर चेकमार्क दिखता है।

"[name]" अपडेट करें

सक्रिय दृश्य पर अपनी वर्तमान डॉक व्यवस्था सहेजें, इसे बदलते हुए।

"[name]" हटाएं

सक्रिय दृश्य को हटाएं (पहले पुष्टि मांगी जाएगी)।

वर्तमान दृश्य को इस नाम से सहेजें...

अपनी वर्तमान डॉक व्यवस्था को एक नए दृश्य के रूप में नामित करें और सहेजें।

सामान्य कार्यप्रवाह:

  1. अपने डॉक्स को ठीक वैसे ही व्यवस्थित करें जैसे आप चाहते हैं।

  2. View → My Views → Save Current View As... खोलें और एक नाम दर्ज करें (जैसे "Audio Mix").

  3. बाद में, View → My Views खोलें और उस लेआउट को तुरंत पुनर्स्थापित करने के लिए दृश्य नाम पर क्लिक करें।

  4. यदि आप लेआउट समायोजित करते हैं और परिवर्तनों को रखना चाहते हैं, तो इसे अधिलेखित करने के लिए Update "Audio Mix" चुनें।

डॉक्स

OpenShot मुख्य विंडो पर प्रत्येक विजेट एक डॉक में होता है। इन डॉक को मुख्य विंडो के चारों ओर खींचा और स्नैप किया जा सकता है, और यहां तक कि एक साथ समूहित (टैब में) भी किया जा सकता है। OpenShot हमेशा आपके मुख्य विंडो डॉक लेआउट को प्रोग्राम से बाहर निकलते समय सहेजता है। OpenShot को पुनः लॉन्च करने पर आपका कस्टम डॉक लेआउट स्वचालित रूप से पुनर्स्थापित हो जाएगा। स्कोप डॉक View->Scopes के अंतर्गत समूहित होते हैं।

डॉक का नाम

विवरण

कैप्शन

अपने वीडियो प्रोजेक्ट में कैप्शन या सबटाइटल जोड़ें और प्रबंधित करें। यह आपको कैप्शन डेटा बनाने, संपादित करने और प्रबंधित करने की अनुमति देता है। देखें कैप्शन प्रभाव।

इफेक्ट्स

अपने वीडियो क्लिप्स पर वीडियो और ऑडियो इफेक्ट्स ब्राउज़ और लागू करें। इसमें फ़िल्टर, रंग समायोजन, और विशेष प्रभाव शामिल हैं। देखें इफेक्ट्स

रंग पहिए

समर्पित दाहिने साइड डॉक से वैश्विक, छायाएं, मध्य टोन, और हाइलाइट्स के लिए रंग ग्रेड पहिया नियंत्रण संपादित करें।

इमोजी

अपने वीडियो प्रोजेक्ट में इमोजी ग्राफिक्स जोड़ें। अपने वीडियो सामग्री को बेहतर बनाने के लिए विभिन्न इमोजी में से चुनें।

हिस्टोग्राम

वर्तमान पूर्वावलोकन फ्रेम के टोनल और चैनल वितरण का विश्लेषण करें।

ल्यूमा वेवफ़ॉर्म

वर्तमान पूर्वावलोकन फ्रेम में चमक वितरण का विश्लेषण करें।

ऑडियो स्तर

वर्तमान पूर्वावलोकन फ्रेम के लिए ऑडियो स्तर स्कोप डेटा की निगरानी करें।

प्रोजेक्ट फाइलें

अपने प्रोजेक्ट में आयातित सभी मीडिया फ़ाइलों को देखें और प्रबंधित करें। वीडियो, ऑडियो, और छवि फ़ाइलों को व्यवस्थित, फ़िल्टर, और टैग करें। देखें फ़ाइलें

गुण

चयनित इफेक्ट, ट्रांज़िशन, या क्लिप की संपत्तियों को देखें और संपादित करें। अवधि, आकार, स्थिति आदि जैसी सेटिंग्स समायोजित करें। देखें क्लिप गुण

रिकॉर्डिंग

माइक्रोफोन ऑडियो, स्क्रीन वीडियो, वेबकैम वीडियो, या संयुक्त रिकॉर्डिंग रिकॉर्ड करें। देखें रिकॉर्डिंग

ट्रांज़िशन

वीडियो क्लिप्स के बीच ट्रांज़िशन ब्राउज़ और लागू करें। दृश्यों के बीच सहज परिवर्तन बनाने के लिए विभिन्न ट्रांज़िशन वाइप्स में से चुनें। देखें ट्रांज़िशन

वीडियो पूर्वावलोकन

अपने वीडियो प्रोजेक्ट की वर्तमान स्थिति का पूर्वावलोकन करें। आपको रीयल-टाइम में अपनी संपादित सामग्री को प्ले और समीक्षा करने की अनुमति देता है। देखें प्लेबैक

यदि आपने गलती से कोई डॉक बंद कर दिया है या हटा दिया है और अब उसे नहीं ढूंढ पा रहे हैं, तो इसके कुछ आसान समाधान हैं। सबसे पहले, आप स्क्रीन के शीर्ष पर View->Simple View मेनू विकल्प का उपयोग करके दृश्य को उसके डिफ़ॉल्ट पर पुनर्स्थापित कर सकते हैं। या आप View->Docks->... मेनू का उपयोग करके मुख्य विंडो पर विशिष्ट डॉक विजेट्स को दिखा या छुपा सकते हैं।