文件
要创建视频,我们需要通过将文件导入 OpenShot,使媒体文件可用于项目。大多数媒体文件类型都被识别,如视频、图像和音频文件。文件可以在**项目文件** 面板中查看和管理。
请注意,导入的文件不会被复制到任何地方,它们仍然保留在原来的物理位置,只是被提供给您的视频项目使用。因此,添加到项目后,文件不能被删除、重命名或移动。文件上方的“显示全部”、“视频”、“音频”、“图像”过滤器允许您只查看感兴趣的文件类型。您还可以在 详细信息 和 :guilabel:` 缩略图` 视图之间切换文件显示方式。
导入文件
有多种方式可以将媒体文件导入 OpenShot 项目。文件导入成功后,会自动被选中并滚动到视图中(在**项目文件** 面板)。如果**项目文件** 面板当前不可见,OpenShot 会自动显示该面板。
导入文件方法 |
描述 |
|---|---|
拖放 |
从文件管理器(文件资源管理器、访达等)拖放文件。 |
上下文菜单 (File Menu) |
在**项目文件** 面板任意位置右键点击,选择 导入文件 。 |
主菜单 |
在主菜单中选择:文件→导入文件 。 |
工具栏按钮 |
点击主工具栏中的 + 按钮。 |
快捷键 |
按 Ctrl-F (Mac 上为 Cmd-F )。 |
从剪贴板粘贴 |
按 Ctrl-V (Mac 上为 Cmd-V )从剪贴板粘贴复制的文件。参见 从剪贴板粘贴 。 |
从剪贴板粘贴
您可以直接将文件和剪贴板媒体粘贴到 OpenShot。如果您在文件管理器中复制了一个或多个文件,切换到 OpenShot 并在**项目文件** 面板按 Ctrl-V 添加它们,就像导入一样。
如果您复制了媒体**数据** (例如,网页浏览器中的**复制图像** ,来自其他应用的粘贴帧,或其他图像/音频/视频剪贴板数据),在 OpenShot 中按 Ctrl-V 会为该剪贴板内容创建一个文件。OpenShot 会将副本保存到临时文件夹:.openshot_qt/clipboard/ 。新文件随后会被添加到您的项目并显示在**项目文件** 中。
预览文件
预览文件 操作会打开来自 项目文件 中所选文件的预览对话框。只需双击文件即可打开此对话框。
播放自动开始。
默认启用循环播放。
按 空格 键切换播放/暂停。
使用鼠标滚轮进行放大/缩小。
当缩放比例不为 100% 时,会显示 重置缩放 按钮,点击可重置为 100%。
优化
优化的预览文件是您源视频文件的低分辨率副本(有时称为代理文件),用于在不更改原始媒体的情况下提高编辑响应速度。它们对4K、高帧率或高比特率等大格式视频特别有帮助。
对于视频文件,文件上下文菜单包含一个 优化 子菜单。此功能创建或链接源剪辑的较小预览副本,可改善较慢系统或高分辨率素材的播放和拖动。优化还会预加载缩略图,进一步提升缩放时间线时的编辑流畅度。
优化 子菜单包含以下操作:
操作 |
描述 |
|---|---|
优化视频 |
为每个选定的视频文件创建优化的预览文件。OpenShot 将这些文件存储在项目的 |
链接到现有文件... |
选择包含已创建优化文件的文件夹,并将最佳匹配的文件链接到所选源剪辑。此功能支持常见的代理命名样式、已知代理后缀、文件ID后缀和扩展名更改。 |
取消链接 |
从所选文件中移除优化预览链接,但不删除磁盘上的优化文件。 |
删除并取消链接 |
从磁盘删除已链接的优化文件,然后从所选文件中移除链接。 |
优化进行时,子菜单会变为针对所选文件的单一 取消 操作。优化的预览文件仅用于编辑和预览播放,最终导出仍使用原始源文件。
使用 链接到现有文件... 时,OpenShot 会按安全顺序尝试将每个选定的源剪辑匹配到现有的优化文件。它首先查找具有不同视频扩展名但相同基本文件名的文件,然后查找常见的代理样式名称,如 _proxy、_preview、_optimized、_lowres,分辨率标签如 _720p 或 _1080p,以及摄像机/编辑器样式变体如 _p。它还支持在已知代理后缀后添加 OpenShot 文件ID的名称,如 clip001_proxy_F1.mp4,并且仍能匹配仅以文件ID命名的文件,如 F1.mp4。
自带优化文件时的最佳做法是保持与源剪辑相同的基本文件名,并添加明确的代理样式后缀,例如 clip001_proxy.mp4 或 clip001_proxy.mov。如果需要避免文件名冲突,可在代理后缀后附加 OpenShot 文件ID,例如 clip001_proxy_F1.mp4。避免使用无关后缀如 _final 或 _reviewcopy,因为 OpenShot 不将其视为安全的代理命名模式。
拆分文件
如果您需要在编辑前将大型视频文件切割成多个小文件,拆分文件 对话框正是为此设计。右键点击文件,选择 拆分文件 。使用此对话框快速将大文件分割成多个小片段。每个片段可以选择起始和结束帧,以及标题。每个片段会作为新文件出现在项目文件对话框中。
编号 |
名称 |
描述 |
|---|---|---|
1 |
文件起始 |
点击此按钮选择文件的起始帧 |
2 |
文件结尾 |
点击此按钮选择文件的结束帧 |
3 |
文件名 |
输入可选名称 |
4 |
创建按钮 |
创建文件(这将重置此对话框,您可以为每个片段重复这些步骤) |
请参阅章节 修剪与切割 了解更多在时间线上直接剪切和分割剪辑的方法。
导出文件
如果您希望在 OpenShot 项目外使用拆分的文件片段,或想将所有视频素材复制到一个位置,可以使用 导出文件 对话框。只需按住 Ctrl 并点击选择所有文件,然后 :kbd:` 右键点击` 并选择 :guilabel:` 导出文件` 。在弹出的对话框中,选择目标文件夹,然后点击 :guilabel:` 导出` 。
注意:这将使用每个文件或文件片段的**原始视频配置** (宽度、高度、帧率、宽高比等)进行导出。它还支持任何 拆分文件 (如上所述)。例如,如果您将一个长视频文件拆分成多个不同的片段(并命名),现在可以将所有片段作为独立视频文件导出(使用原始文件的视频配置)。
添加到时间线
在某些情况下,您可能需要同时将许多文件添加到时间线上。例如,照片幻灯片或大量短视频剪辑。添加到时间线 对话框可以为您自动完成此任务。首先,选择所有需要添加的文件,右键点击,选择“添加到时间线”。
编号 |
名称 |
描述 |
|---|---|---|
1 |
已选文件 |
需要添加到时间线的已选文件列表 |
2 |
文件顺序 |
使用这些按钮重新排序文件列表(上移、下移、随机、移除) |
3 |
时间线位置 |
选择这些文件在时间线上插入的起始位置和轨道 |
4 |
淡入淡出选项 |
淡入、淡出、两者或无(仅影响图像,不影响音频) |
5 |
缩放选项 |
放大、缩小或无 |
6 |
转场 |
选择文件间使用的特定转场、随机或无(仅影响图像,不影响音频) |
属性
要查看视频项目中任何导入文件的属性,右键点击该文件,选择**文件属性** 。这将打开文件属性对话框,显示媒体文件的信息。对于某些类型的图像(如图像序列),您还可以在此对话框中调整帧率。
编号 |
名称 |
描述 |
|---|---|---|
1 |
文件属性 |
在**项目文件** 面板中选择一个图像序列,右键点击并选择**文件属性** |
2 |
帧率 |
对于图像序列,您还可以调整动画的帧率 |
从项目中移除
这将从项目中移除文件,但不会删除其物理文件,因此移除文件仅使其在此视频项目中不可用。
项目素材文件夹
OpenShot 在编辑时会创建并使用一些**临时工作文件夹** 。这些文件夹位于用户配置文件下的 .openshot_qt/ 目录中,存放 OpenShot 为您生成的项目专用文件:
.openshot_qt/blender/- 由动画标题对话框创建的 Blender 动画渲染文件.openshot_qt/title/- 由标题对话框创建的 SVG 标题文件.openshot_qt/thumbnail/- 为项目文件和时间线生成的缩略图.openshot_qt/clipboard/- 从剪贴板粘贴创建的媒体(图像、音频或视频,需先保存到磁盘).openshot_qt/optimized/- 为更流畅编辑创建的优化预览文件.openshot_qt/protobuf_data- 跟踪和目标检测数据
当您选择 文件→另存为 时,OpenShot 会将这些文件夹复制到您的项目目录中,放入名为 PROJECTNAME_Assets 的单一文件夹内。例如:MyProject_Assets/clipboard 将包含您从剪贴板粘贴的任何媒体,MyProject_Assets/optimized 将包含链接到项目的任何优化预览文件。
As part of this process, all paths inside your *.osp project file are updated to be relative to your project folder.
缺失文件
当您在 OpenShot 中创建并保存项目时,导入到软件中的任何文件(如视频、音频和图像)必须在整个项目期间保持可访问。这意味着这些导入的文件不应被重命名、删除或移动到不同的文件夹。此外,这些文件所在的完整路径也不应被重命名。此原则同样适用于其他视频编辑软件。
例如,用户可能会移动或删除文件夹,拔出 USB 设备,或移动或删除项目文件。任何这些情况都会导致出现 缺少文件 提示,OpenShot 会提示您定位缺失文件所在的文件夹。根据您添加到项目中的文件数量,OpenShot 可能会多次提示您查找缺失的文件。
当 OpenShot 保存项目时,所有文件路径都会转换为**相对** 路径。只要您将所有资源保存在同一个父文件夹中(包括 *.osp 项目文件),就可以移动项目文件夹而不会触发任何缺少文件的提示。您甚至可以将自包含的项目文件夹移动到另一台计算机,且不会出现任何问题。
每个人都有自己独特的文件组织方式,但在使用视频编辑器时,务必记住不要更改文件路径、重命名文件或删除文件,因为这可能导致缺少文件的问题。有关缺少文件的详细指南,请参见 缺少文件的案例! 。 The Case of “Missing Files”!