主窗口
OpenShot 视频编辑器有一个主窗口,包含编辑视频项目所需的大部分信息、按钮和菜单。
概览
编号 |
名称 |
描述 |
|---|---|---|
1 |
主工具栏 |
包含打开、保存和导出视频项目的按钮。 |
2 |
功能标签 |
在项目文件、转场、特效和表情符号之间切换。 |
3 |
项目文件 |
所有已导入项目的音频、视频和图像文件。 |
4 |
预览窗口 |
这是视频将在屏幕上播放的区域。 |
5 |
时间轴工具栏 |
此工具栏包含用于吸附、插入标记、切割刀片、在标记间跳转以及将时间轴居中于播放头的按钮。参见 时间轴工具栏 。 |
6 |
缩放滑块 |
此滑块调整时间轴的时间比例。拖动左或右边缘可放大或缩小,拖动蓝色区域可左右滚动时间轴。剪辑和转场以简单矩形显示,方便调整缩放以定位特定剪辑。 |
7 |
播放头 / 标尺 |
标尺显示时间刻度,线条表示播放头。播放头代表当前播放位置。可以点击当前时间码以输入精确的时间码。拖动播放头时按住 Shift 键可吸附到附近的剪辑。 |
8 |
时间轴 |
时间轴可视化您的视频项目及其中的每个剪辑和转场。您可以拖动鼠标选择、移动或删除多个项目。 |
9 |
筛选 |
使用这些按钮和筛选文本框筛选显示的项目列表(项目文件、转场、特效和表情符号)。输入部分文字即可显示匹配结果。 |
10 |
播放控制 |
从左到右:跳到开始、倒带、播放/暂停、快进和跳到结尾 |
11 |
轨道 |
包含轨道名称、轨道菜单以及每个轨道控制(如锁定和关键帧面板图标)的轨道区域。 |
有关 OpenShot 基本使用的逐步说明,请务必阅读 快速教程 。
内置教程
首次启动 OpenShot 时,会显示友好的内置教程,演示并讲解基础知识。点击 下一步 可跳转到下一个主题。您也可以随时从 :guilabel:` 帮助→教程` 菜单再次查看此教程。
轨道与图层
OpenShot 使用轨道来叠加视频和图像。最上面的轨道是顶层,最下面的轨道是底层。如果您熟悉照片编辑软件中的图层概念,那么对这个概念应该很熟悉。OpenShot 会堆叠图层并混合它们,就像照片编辑软件一样。轨道数量不限,但简单的视频项目通常不超过 5 条轨道。
例如,想象一个三轨视频项目
编号 |
名称 |
描述 |
|---|---|---|
1 |
顶层轨道 |
此轨道上的剪辑始终位于最上方且可见。水印和标题通常放在较高的轨道上。 |
2 |
中间轨道 |
中间轨道的剪辑(是否可见取决于其上方的内容) |
3 |
底层轨道 |
此轨道上的剪辑始终位于最底层。音频剪辑通常放在较低的轨道上。 |
时间轴工具栏
有关时间线编辑(选择、轨道、关键帧和常见工作流程)的初学者友好概述,请参见 时间轴。
编号 |
控制组 |
描述 |
|---|---|---|
1 |
添加轨道 |
向时间轴添加新轨道。新项目默认有 5 条轨道。 |
2 |
撤销 / 重做 |
撤销或重做您最近的时间线编辑。 |
3 |
吸附、重定时、剃刀 |
吸附切换磁性对齐。时间工具通过拖动剪辑边缘实现重定时。剃刀工具在点击位置剪切剪辑。 |
4 |
添加标记,前一个/下一个标记 |
在播放头处添加标记,并跳转到前一个或下一个标记/剪辑边界。 |
5 |
居中播放头 |
将可见时间线区域居中于当前播放头位置。 |
6 |
缩放滑块 |
控制可见的时间线范围。拖动把手以放大/缩小,拖动中心以平移,双击以适应时间线。您还可以使用 Ctrl+滚轮,或者在 QWidget 时间线上按住 Ctrl 并用中键拖动以实现平滑缩放。 |
7 |
轨道切换(锁定,关键帧面板) |
每个轨道的控制,如锁定和关键帧面板的可见性。 |
键盘快捷键
以下是 OpenShot 支持的默认键盘快捷键列表。您可以在“首选项”窗口中配置这些快捷键,该窗口可通过 OpenShot 菜单栏选择 编辑→首选项 打开。(在 macOS 上,选择 OpenShot Video Editor→首选项 。)掌握其中一些快捷键可以节省大量时间!
操作 |
快捷键 1 |
快捷键 2 |
快捷键 3 |
|---|---|---|---|
关于 OpenShot |
Ctrl+H |
||
添加标记 |
M |
||
添加轨道 |
Ctrl+Y |
||
添加到时间轴 |
Ctrl+Alt+A |
||
动画标题 |
Ctrl+Shift+T |
||
提问... |
F4 |
||
居中播放头 |
Shift+C |
Alt+Up |
|
颜色视图 |
Alt+Shift+2 |
||
选择配置文件 |
Ctrl+Alt+P |
||
清除所有缓存 |
Ctrl+Shift+ESC |
||
清除历史记录 |
Ctrl+Shift+H |
||
删除优化视频 |
Ctrl+Shift+O |
||
清除波形显示数据 |
Ctrl+Shift+W |
||
复制 |
Ctrl+C |
||
剪切 |
Ctrl+X |
||
删除项目 |
Delete |
Backspace |
|
删除项目(波纹) |
Shift+Delete |
||
详细视图 |
Ctrl+Page Up |
||
捐赠 |
F7 |
||
复制 |
Ctrl+Shift+/ |
||
编辑标题 |
Alt+T |
||
导出选中文件 |
Ctrl+Shift+E |
||
导出视频/媒体 |
Ctrl+E |
Ctrl+M |
|
快进 |
L |
||
文件属性 |
Alt+I |
Ctrl+Double Click |
|
全屏 |
F11 |
||
导入文件... |
Ctrl+I |
||
插入关键帧 |
Alt+Shift+K |
||
加入我们的社区... |
F5 |
||
跳转到结尾 |
End |
||
跳转到开始 |
Home |
||
启动教程 |
F2 |
||
新建项目 |
Ctrl+N |
||
下一帧 |
Right |
. |
|
下一个标记 |
Shift+M |
Alt+Right |
|
向左微调(1帧) |
Ctrl+Left |
||
向左微调(5帧) |
Shift+Ctrl+Left |
||
向右微调(1帧) |
Ctrl+Right |
||
向右微调(5帧) |
Shift+Ctrl+Right |
||
打开帮助内容 |
F1 |
||
打开项目... |
Ctrl+O |
||
粘贴 |
Ctrl+V |
||
播放/暂停切换 |
Space |
Up |
Down |
首选项 |
Ctrl+P |
||
预览文件 |
Alt+P |
双击 |
|
上一帧 |
Left |
, |
|
上一个标记 |
Ctrl+Shift+M |
Alt+Left |
|
属性 |
U |
||
退出 |
Ctrl+Q |
||
剃刀工具切换 |
C |
B |
R |
重做 |
Ctrl+Shift+Z |
||
报告错误... |
F3 |
||
倒带 |
J |
||
保存当前帧 |
Ctrl+Shift+Y |
||
保存当前帧 |
Ctrl+Shift+Y |
||
保存项目 |
Ctrl+S |
||
项目另存为... |
Ctrl+Shift+S |
||
全选 |
Ctrl+A |
||
选择项目(波纹) |
Alt+A |
Alt+点击 |
|
取消选择 |
Ctrl+Shift+A |
||
简易视图 |
Alt+Shift+0 |
||
全部切片:保留两侧 |
Ctrl+Shift+K |
||
全部切片:保留左侧 |
Ctrl+Shift+J |
||
全部切片:保留右侧 |
Ctrl+Shift+L |
||
切片选中:保留两侧 |
Ctrl+K |
||
切片选中:保留左侧 |
Ctrl+J |
||
切片选中:保留右侧 |
Ctrl+L |
||
切片选中:保留左侧(波纹) |
W |
||
切片选中:保留右侧(波纹) |
Q |
||
吸附切换 |
S |
||
拆分文件 |
Alt+S |
Shift+双击 |
|
缩略图视图 |
Ctrl+向下翻页 |
||
时间切换 |
T |
||
标题 |
Ctrl+T |
||
翻译此应用程序... |
F6 |
||
撤销 |
Ctrl+Z |
||
查看工具栏 |
Ctrl+Shift+B |
||
放大 |
= |
Ctrl+= |
|
缩小 |
- |
Ctrl+- |
|
缩放到时间线 |
\ |
Shift+\ |
双击 |
关于 OpenShot
使用 帮助→关于 OpenShot 来检查您的 OpenShot 版本。点击版本号旁的 复制,复制简短的版本和系统详细信息报告,这是报告错误或寻求帮助时推荐的分享方式。
示例输出:
**OpenShot Version Info**
Version: 3.5.1-dev | libopenshot: 0.7.0
OS: Ubuntu 24.04
CPU: AMD Ryzen 7 8840HS w/ Radeon 780M Graphics (16 threads) | RAM: 15 GB
Cache: Memory, 900 MB, 905 frames, ahead 50%, pre-roll 24/48
Performance: Threads: OMP 16 | FFmpeg 16, Cards: Decode: None (0) | Encode: 0
视图
OpenShot 主窗口由多个 停靠 组成。这些 停靠 被排列并吸附在一起形成一个我们称之为 视图 的分组。OpenShot 包含 简单视图、颜色视图 和 :guilabel:`我的视图`(用户定义的布局)。
简易视图
这是 默认 视图,设计为易于使用,特别适合首次使用者。它包含左上角的 项目文件,右上角的 预览窗口,以及底部的 时间线。如果您不小心关闭或移动了停靠,可以使用屏幕顶部的 视图->简单视图 菜单快速将所有停靠重置回默认位置。
颜色视图
此视图专注于颜色校正和示波器。它放大视频预览,隐藏文件管理停靠,保持时间线和属性可见,将 色轮 停靠放置在右侧,并将 亮度波形 和 直方图 停靠合并为标签,置于其下方。
录制视图
此视图专注于在 OpenShot 内创建新录制。它显示 项目文件、视频预览、时间线 和 录制 停靠。属性 停靠与 项目文件 作为标签分组,因此您可以通过 视图->停靠->属性 显示它,而不会破坏录制布局。
录制 停靠可以录制麦克风音频、屏幕捕获、网络摄像头视频,或这些来源的组合。当屏幕和摄像头同时录制时,OpenShot 可以将摄像头作为画中画角落剪辑放置。这些角落摄像头剪辑在添加到时间线后使用普通剪辑属性:重力 选择角落,缩放 X 和 缩放 Y 设置角落大小,边距 创建内嵌布局区域,使摄像头远离屏幕边缘,圆角半径 使摄像头剪辑圆角而无需添加单独的遮罩效果。详情见 剪辑属性。完整录制工作流程和所有来源选项见 录制。
我的视图
我的视图 允许您将任何停靠排列保存为命名布局并即时调用。对于需要在不同编辑模式之间切换的工作流程非常理想——例如,详细的音频混合布局和专注的颜色分级布局——无需每次手动重新定位停靠。
每个保存的视图都会捕获每个停靠的位置、大小和可见性,以及时间线高度。保存的视图存储在您的项目设置中,并在会话间保持。
视图 → 我的视图 菜单选项:
菜单项 |
描述 |
|---|---|
用户定义视图列表 |
点击以恢复该布局。当前激活的视图显示勾选标记。 |
更新“[name]” |
将当前停靠排列保存覆盖到激活视图,替换它。 |
删除“[name]” |
移除激活视图(会先询问确认)。 |
另存当前视图为... |
为当前停靠排列命名并保存为新视图。 |
典型工作流程:
将停靠面板按您喜欢的方式排列。
打开 视图 → 我的视图 → 另存当前视图为... 并输入名称(例如 “音频混合”)。
之后,打开 视图 → 我的视图 并点击视图名称即可立即恢复该布局。
如果您调整了布局并想保留更改,选择 更新“音频混合” 来覆盖它。
停靠窗口
OpenShot 主窗口上的每个小部件都包含在一个**停靠区**中。这些停靠区可以被拖动并固定在主窗口周围,甚至可以组合在一起(形成标签页)。当您退出程序时,OpenShot 会自动保存您的主窗口停靠区布局。重新启动 OpenShot 会自动恢复您的自定义停靠区布局。范围停靠区归类在 View->Scopes 下。
停靠窗口名称 |
描述 |
|---|---|
字幕 |
管理并添加字幕或字幕到您的视频项目。允许您创建、编辑和管理字幕数据。参见 字幕 效果。 |
效果 |
浏览并应用视频和音频效果到您的视频剪辑。包括滤镜、色彩调整和特殊效果。参见 效果 。 |
色轮 |
从专用的右侧停靠区编辑全局、阴影、中间调和高光的色彩分级轮控件。 |
表情符号 |
向您的视频项目添加表情符号图形。从各种表情符号中选择,增强您的视频内容。 |
直方图 |
分析当前预览帧的色调和通道分布。 |
亮度波形 |
分析当前预览帧的亮度分布。 |
音频电平 |
监控当前预览帧的音频电平范围数据。 |
项目文件 |
查看并管理导入到项目中的所有媒体文件。组织、筛选和标记视频、音频和图像文件。参见 文件 。 |
属性 |
查看并编辑所选效果、转场或剪辑的属性。调整持续时间、大小、位置等设置。参见 剪辑属性 。 |
录制 |
录制麦克风音频、屏幕视频、摄像头视频或组合录制。参见 录制。 |
转场 |
浏览并应用视频剪辑之间的转场。选择各种转场擦除效果,创建场景间的平滑过渡。参见 转场 。 |
视频预览 |
预览视频项目的当前状态。允许您实时播放和回顾编辑内容。参见 播放 。 |
如果您不小心关闭或移动了停靠区,导致找不到它,有几个简单的解决方法。首先,您可以使用屏幕顶部的 View->Simple View 菜单选项,将视图恢复为默认状态。或者,您可以使用 View->Docks->... 菜单来显示或隐藏主窗口上的特定停靠小部件。