檔案

要製作影片,我們需要透過匯入檔案到 OpenShot,讓媒體檔案可用於專案中。大多數媒體檔案類型都能被識別,例如影片、圖片和音訊檔案。檔案可在 專案檔案 面板中檢視和管理。

請注意,匯入的檔案不會被複製到其他地方,它們仍保留在原本的實體位置,只是被提供給您的影片專案使用。因此,加入專案後,請勿刪除、重新命名或移動這些檔案。檔案上方的「顯示全部」、「影片」、「音訊」、「圖片」篩選器可讓您只查看感興趣的檔案類型。您也可以切換檔案的 詳細資料 與 :guilabel:` 縮圖` 檢視。

匯入檔案

有多種方式可將媒體檔案匯入 OpenShot 專案。成功匯入檔案後,該檔案會自動被選取並捲動至可見範圍(在 專案檔案 面板中)。若 專案檔案 面板目前未顯示,OpenShot 也會自動顯示該面板。

匯入檔案方式

說明

拖放

從檔案管理員(檔案總管、Finder 等)拖放檔案。

內容選單 (File Menu)

在 專案檔案 面板任意處點擊右鍵,選擇 匯入檔案 。

主選單

在主選單中選擇:檔案→匯入檔案 。

工具列按鈕

點擊主工具列中的 + 按鈕。

快捷鍵

按下 Ctrl-F (Mac 上為 Cmd-F )。

從剪貼簿貼上

按下 Ctrl-V (Mac 上為 Cmd-V )從剪貼簿貼上複製的檔案。參見 從剪貼簿貼上 。

../_images/quick-start-drop-files.jpg

從剪貼簿貼上

您可以直接將檔案和剪貼簿媒體貼入 OpenShot。如果您在檔案管理員中複製了一個或多個檔案,切換到 OpenShot 並在 專案檔案 面板按 Ctrl-V ,即可像匯入一樣新增它們。

如果您複製的是媒體資料 (例如,網頁瀏覽器中的複製圖片 、從其他應用程式貼上的影格,或其他影像/音訊/影片剪貼簿資料),在 OpenShot 按 Ctrl-V ,將為該剪貼簿內容建立檔案。OpenShot 會將副本儲存在暫存資料夾:.openshot_qt/clipboard/ 。新檔案隨後會加入您的專案並顯示在 專案檔案 中。

檔案選單

要查看檔案選單,請在檔案(位於 專案檔案 面板)上點擊右鍵。以下是您可以使用的檔案選單操作。

../_images/file-menu.jpg

檔案內容選項

說明

匯入檔案...

將檔案匯入您的專案

使用 AI 創建 / 使用 AI 強化(可選)

AI 功能表操作,用於生成或強化媒體文件。這些選項僅在啟用 AI 且所選文件類型支持此工作流程時顯示。請參閱 進階 AI:ComfyUI。

詳細視圖

將專案文件面板切換為詳細視圖

預覽檔案

預覽媒體檔案

分割檔案

將檔案分割成多個較小的檔案。新的裁剪檔案會出現在專案檔案列表中。

匯出檔案

匯出選取的文件(及分割片段)到目標資料夾

加入時間軸

一次將多個檔案加入時間軸,包括轉場或交替軌道。

選擇設定檔

將目前專案設定檔更改為符合所選檔案。如果檔案的設定檔不符合已知設定檔,將提供建立自訂設定檔的選項。

檔案屬性

檢視檔案屬性,例如影格率、大小等...

優化

為所選影片檔案建立、連結、取消連結或刪除優化的預覽檔案。

從專案移除

從專案中移除檔案

編輯標題

編輯現有的標題 SVG 文件(選擇 SVG 標題時顯示)

複製標題

Make a copy, and then edit the copied title SVG file (shown when an SVG title is selected)

預覽檔案

預覽檔案 動作會開啟從 專案檔案 中選取的檔案的預覽對話框。雙擊檔案,或在檔案列表聚焦時按 Shift+2 或 Alt+P。在時間軸聚焦時,相同的快速鍵會從起點播放選取的剪輯。您也可以右鍵點擊時間軸剪輯並選擇 預覽剪輯。雙擊已儲存的分割會重新開啟其範圍編輯器,而非唯讀預覽。

  • 當您開啟預覽或分割檔案時,播放會自動開始。

  • 循環 會重複播放,且在預覽中預設為啟用。

  • 點擊喇叭圖示可靜音預覽音訊,而不會改變專案設定。

  • 點擊或拖曳音量滑桿以調整預覽音訊,且不會影響匯出影片。儲存專案以記住此音量設定於所有預覽中。

  • 使用「適合視窗」將影片區域調整為來源的長寬比。來源中已編碼的黑邊仍會顯示。

  • 播放期間尋找會持續播放。拖曳調整大小、移動或繪製範圍時會暫停播放,以便檢視邊界影格。

  • 按 空白鍵 切換播放/暫停。

  • 使用滑鼠滾輪進行放大/縮小。

  • 當縮放比例非 100% 時,會顯示 重設縮放 按鈕,點擊可重設為 100%。

調整視窗大小或最大化以符合您的工作空間。預覽和分割檔案會在您儲存專案時記住視窗大小。

尺規下方的彩色條顯示已載入播放的區段。若播放不流暢,請嘗試縮小視窗或 優化檔案。

預覽檔案僅顯示播放和拖曳控制。預覽剪輯和分割檔案在共用預覽下方新增範圍編輯。來源尺規和膠片條顯示完整錄製,並以高亮標示選取範圍。拖曳任一控制點可調整範圍並移動播放頭。拖曳膠片條上方的尺規可拖曳播放而不改變範圍。編輯起始和結束時間碼以精確設定邊界,或點擊旁邊的時鐘按鈕以使用目前播放頭位置 (I / O)。結束為最後包含的影格;一影格範圍有效。持續時間顯示選取範圍長度,可編輯以移動結束點並保持起始點固定。持續時間限制至少一影格,最多為剩餘來源長度。播放旁的按鈕可跳至起始和結束。

編輯時間軸剪輯時,更新剪輯 僅更新該剪輯。其位置保持固定,持續時間變更;鄰近剪輯不會移動。鎖定或重新定時的剪輯可預覽,但無法套用範圍。重設 會重新載入已儲存的範圍。每次更新為一個復原步驟。

分割檔案提供起始、結束、持續時間及可選的名稱欄位,旁邊有 建立 按鈕。每次點擊會建立一個專案檔案條目,並保持視窗開啟以建立另一個。在名稱欄或時間欄外按 Enter 會儲存並關閉編輯器。在起始、結束或持續時間欄按 Enter 則提交數值並保持編輯器開啟。Tab 鍵可在起始、結束、持續時間和名稱間切換;Shift+Tab 則反向切換。每次建立為一個復原步驟。開啟現有分割可更新其範圍和名稱,而不改變現有時間軸剪輯。更新 會儲存分割並關閉編輯器,刷新檔案及依賴剪輯縮圖。更新剪輯 會儲存並關閉剪輯預覽。使用視窗關閉控制或 Esc 可關閉而不套用變更。

拖曳膠片條控制點以修剪,拖曳選取範圍內部以移動,或拖曳外部以繪製新範圍。點擊以尋找,或拖曳尺規以拖曳播放而不改變範圍。

若修改的範圍在專案其他處變更,請捨棄本地變更並重新載入後再儲存。當主視窗選擇變更時,對話框仍會附著於其原始來源或時間軸剪輯。

優化

優化的預覽檔案是您原始影片檔案的低解析度副本(有時稱為代理檔案),用於提升編輯反應速度而不改變原始媒體。對於 4K、高幀率或高位元率等大型格式特別有幫助。

自動優化

當 OpenShot 建立影片的第一個縮圖時,會記錄產生第一影格所需時間。這利用了在專案檔案中顯示影片已需的工作,無需額外解碼測試。縮圖影格時間超過 自動優化門檻 的影片,可能會從較小的預覽副本中受益。

在預設的 詢問 偏好設定下,當 OpenShot 在尚未有儲存選擇的專案中找到符合條件的影片時,會顯示橫幅:

優化影片以獲得更流暢的播放? 原始檔和匯出品質保持不變。

點擊 自動優化 以啟用目前專案的自動優化。橫幅會立即消失,符合條件的影片會加入優化佇列。您之後匯入的影片若符合條件,也會加入佇列,即使已有其他影片正在優化。系統不會對每個檔案再次詢問。

優化進行時您可以繼續編輯。沒有進度橫幅;進度會顯示在專案檔案中的檔案上。

點擊 稍後再說 或關閉橫幅以拒絕。OpenShot 會在您儲存專案時記住您的選擇,因此重新開啟專案或匯入更多影片時不會重複顯示建議。若要更改您的選擇,請勾選或取消勾選 檔案 ‣ 自動優化,或按 Ctrl+Alt+O(macOS 上為 Command+Alt+O)。您可以在 編輯 ‣ 偏好設定 ‣ 鍵盤 中自訂此快捷鍵。關閉此功能會停止新的自動工作;已開始的工作可透過檔案的 優化 子選單取消。現有的優化副本仍然可用。

在 編輯 ‣ 偏好設定 中,打開 優化 分頁(參見 優化):

  • 自動優化:詢問 會顯示橫幅,且為預設值。總是 會在不顯示橫幅的情況下優化符合條件的影片。從不 則停用建議和自動處理。這些預設適用於沒有儲存選擇的專案;專案自身的設定優先。

  • 自動優化門檻:預設為 200 毫秒。較低的值包含更多影片;較高的值包含較少。此數值測量的是產生第一個縮圖影格的時間,而非開啟檔案、儲存縮圖或排隊等待的時間。

  • 優化預覽解析度 和 同時優化工作數 控制預覽副本及一次可處理的影片數量。

縮圖時間會與專案中的每個檔案一起儲存。當您在同一台電腦上重新開啟專案時,OpenShot 會重複使用有效的時間。若來源檔案已更改或使用不同電腦,則需要重新測量。開啟舊專案時,OpenShot 會在背景中逐一更新缺失的時間,優先檢查時間軸上使用的影片。播放期間會暫停新的檢查。播放緩慢的影片會觸發相同的橫幅;接受後也會檢查並排隊剩餘影片。啟用 檔案 → 自動優化 也會啟動這些檢查。選擇 從不 或關閉橫幅會停止該專案的進一步檢查。請儲存專案以保留時間,下次使用。您也可以隨時手動優化影片。

門檻值僅供參考,並非播放效能的保證。其他應用程式可能影響時間,且特效或重疊剪輯會獨立於來源影片減慢播放速度。優化副本會佔用專案資產資料夾的額外磁碟空間;原始檔案和匯出品質保持不變。取消或失敗的自動工作在當前專案階段不會自動重試。

關閉 OpenShot 會取消排隊和正在進行的優化工作。正在執行的工作會先完成當前處理步驟後再關閉,未完成的預覽檔案會被移除。

優化狀態

將滑鼠懸停於專案檔案中的檔案上,即可看到檔名及簡短狀態:

工具提示狀態

含義

排隊等待優化

等待可用的優化工作槽位。

優化中以提升播放流暢度 — 35%

正在建立預覽副本。百分比顯示進度。

已優化以提升播放流暢度

預覽副本已準備好使用。

取消優化中

停止當前工作並清理未完成的副本。

缺少優化預覽

找不到連結的預覽副本。請使用「優化影片」重新建立,或連結現有副本。

要停止排隊或正在執行的工作,請右鍵點擊檔案並選擇 優化 ‣ 取消。取消工作不會關閉 檔案 ‣ 自動優化,後續匯入仍會自動優化。

手動優化

對於影片檔案,檔案內容選單包含一個 優化 子選單。此功能會建立或連結較小的預覽副本,能改善較慢系統或高解析度影片的播放與拖曳。優化還會預先載入縮圖,進一步提升在時間軸放大時的編輯流暢度。

優化 子選單包含以下操作:

操作

說明

優化影片

為每個所選影片檔案建立優化的預覽檔案。OpenShot 將這些檔案儲存在專案的 optimized 資產資料夾中。

連結至現有檔案...

選擇一個包含已建立優化檔案的資料夾,並將最佳匹配的檔案連結到所選的原始剪輯。此功能支援常見的代理命名樣式、已知代理後綴、檔案 ID 後綴及副檔名變更。

取消連結

從所選檔案移除優化預覽連結,但不刪除磁碟上的優化檔案。

刪除並取消連結

從磁碟刪除已連結的優化檔案,然後從所選檔案移除連結。

當優化進行中,子選單會變成針對所選檔案的單一 取消 操作。優化的預覽檔案僅用於編輯和預覽播放,最終匯出仍會使用原始檔案。

當您使用 連結至現有檔案... 時,OpenShot 會以安全順序嘗試將每個所選原始剪輯與現有優化檔案匹配。它會先尋找相同基底檔名但不同影片副檔名的檔案,接著尋找常見的代理風格名稱,如 _proxy、_preview、_optimized、_lowres,解析度標籤如 _720p 或 _1080p,以及攝影機/編輯器風格變體如 _p。它也支援在已知代理後綴後加上 OpenShot 檔案 ID 的名稱,例如 clip001_proxy_F1.mp4,並且仍能匹配僅以檔案 ID 命名的檔案,如 F1.mp4。

自行提供優化檔案的最佳做法是保持與原始剪輯相同的基底檔名,並加上明確的代理風格後綴,例如 clip001_proxy.mp4 或 clip001_proxy.mov。若需避免檔名衝突,可在代理後綴後附加 OpenShot 檔案 ID,例如 clip001_proxy_F1.mp4。避免使用無關的後綴如 _final 或 _reviewcopy,因為 OpenShot 不會將其視為安全的代理命名模式。

分割檔案

使用 分割檔案 來選擇您想處理的較長錄影片段。在 專案檔案 中右鍵點擊檔案,選擇 分割檔案。選擇片段的開始和結束,給予可選名稱,然後點擊 建立。調整標記並重複此操作,以準備所需的多個片段。

每個片段都會出現在專案檔案中,並可像其他檔案一樣加入時間軸。這些片段皆使用磁碟上的原始媒體,因此您可以準備它們而無需製作錄影的額外副本。

當您將片段加入時間軸時,OpenShot 會將其屬性的起始關鍵影格設在片段的開始處。例如,啟用 自動關鍵影格 後,您可以移動到結尾並改變旋轉,使其在該片段長度內旋轉。動畫從您選擇使用的部分開始。

如果您已對時間軸剪輯進行動畫處理,切割它會保留該動畫。分割檔案功能適合在開始動畫工作前選擇片段。

預覽現有的分割檔案條目以調整其儲存的進入/退出範圍。尺規包含周圍的畫面,讓您可以在不重新匯入來源的情況下再次延長範圍。

請參考章節 修剪與切割 以了解更多直接在時間軸中剪輯和切割片段的方法。

匯出檔案

如果您想讓分割的檔案片段在 OpenShot 專案外可用,或想將所有影片素材複製到同一位置,可以使用 匯出檔案 對話框。只需按住 Ctrl 並點擊選取所有檔案,然後 :kbd:` 右鍵點擊` 並選擇 :guilabel:` 匯出檔案` 。在出現的對話框中,選擇目標資料夾,然後點擊 :guilabel:` 匯出` 。

注意:這將使用每個檔案或片段的 原始影片設定檔 (寬度、高度、幀率、長寬比等)來匯出。它也支援任何 分割檔案 (如上所述)。例如,如果您將一個長影片檔分割成多個不同片段(並命名),現在可以將所有片段匯出為獨立的影片檔(使用原始檔案的影片設定檔)。

加入時間軸

在某些情況下,您可能需要同時將多個檔案加入時間軸。例如,照片幻燈片或大量短影片片段。加入時間軸 對話框可以自動化此任務。首先,選取所有要加入的檔案,右鍵點擊,然後選擇加入時間軸。

../_images/file-add-to-timeline.jpg

編號

名稱

說明

1

已選取的檔案

需要加入時間軸的已選取檔案清單

2

檔案順序

使用這些按鈕重新排序檔案清單(上移、下移、隨機、移除)

3

時間軸位置

選擇這些檔案要插入時間軸的起始位置和軌道

4

淡入淡出選項

淡入、淡出、兩者或無(僅影響影像,不影響音訊)

5

縮放選項

放大、縮小或無

6

轉場

選擇檔案間使用的特定轉場、隨機或無(僅影響影像,不影響音訊)

屬性

要查看影片專案中任何匯入檔案的屬性,請右鍵點擊該檔案,並選擇 檔案屬性 。這將開啟檔案屬性對話框,顯示媒體檔案的資訊。對於某些類型的影像(例如影像序列),您也可以在此對話框調整幀率。

../_images/file-properties.jpg

編號

名稱

說明

1

檔案屬性

在 專案檔案 面板中選擇影像序列,右鍵點擊並選擇 檔案屬性

2

幀率

對於影像序列,您也可以調整動畫的幀率

從專案移除

從 專案檔案 中移除條目不會刪除磁碟上的原始媒體。

您可以在需要時再次匯入該檔案。例如,在準備好幾個 分割檔案片段 並從專案檔案中移除原始檔案後,您可能想使用錄製的不同部分。再次匯入它以處理整個錄製;您現有的片段將保持不變。如果原始檔案已存在於專案檔案中,再次匯入會選取它。

專案資產資料夾

OpenShot 在編輯時會建立並使用一些 臨時工作資料夾 。這些資料夾位於您的使用者設定檔下的 .openshot_qt/ ,用來存放 OpenShot 為您產生的專案專用檔案:

  • .openshot_qt/blender/ - 由動畫標題對話框產生的 Blender 動畫渲染檔

  • .openshot_qt/title/ - 由標題對話框產生的 SVG 標題檔

  • .openshot_qt/thumbnail/ - 為專案檔案和時間軸產生的縮圖

  • .openshot_qt/clipboard/ - 從剪貼簿貼上產生的媒體(影像、音訊或影片,必須先儲存到磁碟)

  • .openshot_qt/optimized/ - 為更流暢的編輯而建立的優化預覽檔案

  • .openshot_qt/protobuf_data - 追蹤與物件偵測資料

當您選擇 檔案→另存新檔 時,OpenShot 會將這些資料夾複製到您的專案目錄中,放在名為 PROJECTNAME_Assets 的單一資料夾內。例如:MyProject_Assets/clipboard 將包含您從剪貼簿貼上的任何媒體,而 MyProject_Assets/optimized 則包含與專案連結的任何優化預覽檔案。

As part of this process, all paths inside your *.osp project file are updated to be relative to your project folder.

遺失的檔案

當您在 OpenShot 中建立並儲存專案時,任何匯入軟體的檔案(例如影片、音訊和圖片)必須在專案期間保持可存取。這表示這些匯入的檔案不應被重新命名、刪除或移動到不同的資料夾。此外,這些檔案所在的完整路徑也不應被重新命名。此原則同樣適用於其他影片編輯軟體。

例如,使用者可能會移動或刪除資料夾、拔除 USB 裝置,或移動或刪除專案檔案。任何這些情況都會導致出現 遺失檔案 訊息,OpenShot 會提示您定位遺失檔案的資料夾。根據您加入專案的檔案數量,OpenShot 可能會多次提示您尋找遺失的檔案。

當 OpenShot 儲存專案時,所有檔案路徑都會轉換為相對 路徑。只要您將所有資源都整理在同一個父資料夾中(包括 *.osp 專案檔),就能移動專案資料夾而不會觸發任何遺失檔案的提示。您甚至可以將自包含的專案資料夾移動到另一台電腦,且不會有任何問題。

每個人都有自己獨特的檔案整理方式,但在使用影片編輯器時,務必記得不要更改檔案路徑、重新命名檔案或刪除檔案,因為這可能導致遺失檔案的問題。關於遺失檔案的詳細指南,請參閱 The Case of “Missing Files”! 。